Veeva CRM Minor Release - Production - Asia Pacific Region
Maintenance
in progress (1 hour 14 minutes)
February 20 2025,10:00am PST
Veeva CRM Minor Release - Production - Asia Pacific Region
Status: in progress
Start:
February 20 2025,10:00am PST
Estimated Duration: 180 minutes
Affected Components:
Veeva CRM
Veeva MultiChannel & Integrations
MC-30
AP Region
CRM-30
Update
February 20 2025,10:00am PST
February 20 2025,10:00am PST
Veeva CRM Production and Sandbox orgs will be upgraded to the 24R3.4 Minor Release. Systems are generally available during this time.
© 2024 Veeva Trust Site