Veeva CRM Minor Release - Sandbox - Europe Region
Maintenance
February 13 2025,6:00pm PST
Veeva CRM Minor Release - Sandbox - Europe Region
Status: closed
Start:
February 13 2025,2:00pm PST
End:
February 13 2025,6:00pm PST
Duration: 4 hours
Affected Components:
Veeva CRM
Veeva MultiChannel & Integrations
MC-01
MC-20
EU Region
ENGAGE-01
CRM-20
Update
February 13 2025,2:00pm PST
February 13 2025,2:00pm PST
Veeva CRM Sandbox orgs will be upgraded to the 24R3.4 Minor Release. Systems are generally available during this time.
Resolved
February 13 2025,6:00pm PST
February 13 2025,6:00pm PST
Scheduled Maintenance closed.
© 2024 Veeva Trust Site