Veeva CRM Maintenance Release - All Regions

Maintenance
January 24 2025,12:00pm PST

Veeva CRM Maintenance Release - All Regions

Status: closed
Start: January 24 2025,10:00am PST
End: January 24 2025,12:00pm PST
Duration: 2 hours
Affected Components:
Veeva CRM US Region EU Region AP Region CRM-20 CRM-30 CRM-03 CRM-04 CRM-05 CRM-06 CRM-08 CRM-10
Update

January 24 2025,10:00am PST

January 24 2025,10:00am PST

Veeva CRM Sandbox and Production orgs will be upgraded to the 243.0.500 release for Windows platforms. Systems are generally available during this time.

View Patch Notes

Resolved

January 24 2025,12:00pm PST

January 24 2025,12:00pm PST

Scheduled Maintenance closed.