Veeva Align Production Release - Americas Region

Maintenance
January 23 2025,10:00pm PST

Veeva Align Production Release - Americas Region

Status: closed
Start: January 23 2025,6:00pm PST
End: January 23 2025,10:00pm PST
Duration: 4 hours
Affected Components:
Veeva Align VA-US VA-US-2 VA-US-3 VA-US-SBX
Update

January 23 2025,6:00pm PST

January 23 2025,6:00pm PST

Update: Deployment has been moved to 1/23.


Veeva Align production and sandbox instances will be upgraded to the 24R3.2 Align release. Veeva Align environments will not be available during this time and running processes may be interrupted.


View Align Release Notes


View Vault Release Notes

Resolved

January 23 2025,10:00pm PST

January 23 2025,10:00pm PST

Scheduled Maintenance closed.