eCOA Vault 24R3.0 Limited Release Notification - Downtime Required

Maintenance
November 22 2024,11:41am PST

eCOA Vault 24R3.0 Limited Release Notification - Downtime Required

Status: closed
Start: November 22 2024,11:00am PST
End: November 22 2024,11:41am PST
Duration: 41 minutes
Affected Components:
ePRO Vault ePRO Vault-US VV1-1179
Update

November 22 2024,11:00am PST

November 22 2024,11:00am PST

eCOA Vault Release Notification

 
What: eCOA Vault 24R3.0 Limited Release Upgrade
Estimated Duration: 1 to 2 hours
Affected POD: Limited Release POD (VV1-1179)

The upgrade is expected to take approximately 10 minutes, during which time your limited release eCOA Vault will be unavailable for use. Users can continue to work as normal and will be notified in eCOA Vault just before the expected downtime.

What's New
  • See About the Release for release details and the impact assessment.
  • Read What's New for in-depth information about the new features.
  • The Releases tab on Veeva Connect has additional resources about key features in this release. Join the eCOA community to stay informed.
Help & Support
  • See Vault POD Details to learn how to find your Vault’s POD location.
  • See the Veeva Trust Site for updates regarding system availability. ePRO Vault availability is reported under ePRO Vault, and MyVeeva availability under MyVeeva (ePRO, eConsent).
If you have additional questions, please submit a ticket to Veeva Product Support.

Resolved

November 22 2024,11:41am PST

November 22 2024,11:41am PST

Scheduled Maintenance closed.