ePRO Vault 24R3 Release Notice (Self-Serve Pre-Release) - Downtime Required

Maintenance
November 20 2024,1:00pm PST

ePRO Vault 24R3 Release Notice (Self-Serve Pre-Release) - Downtime Required

Status: closed
Start: November 20 2024,10:00am PST
End: November 20 2024,1:00pm PST
Duration: 3 hours
Affected Components:
ePRO Vault ePRO Vault-US VV1-1182
Update

November 20 2024,10:00am PST

November 20 2024,10:00am PST

ePRO Vault Release Notification

 
What: ePRO Vault 24R3 Pre-Release Upgrade
Estimated Duration: 1 to 3 hours
Affected POD: Pre-Release POD (VV1-1182)

The upgrade is expected to take approximately 10 minutes, during which time your pre-release ePRO Vault will be unavailable for use. Users can continue to work as normal and will be notified in ePRO Vault just before the expected downtime.

The 24R3 Vault self-serve pre-release functionality was enabled for all production ePRO Vaults (PODs VV1-1188, VV2-2144, VV3-3130) on November 4. If you don't have a production Vault, pre-release capability was enabled on your sandbox Vault (POD VV1-1182).

The 24R3 Pre-Release Program will conclude on January 13, 2024.

What's New
  • See About the Release for release details and the impact assessment.
  • Read What's New for in-depth information about the new features.
  • The Releases tab on Veeva Connect has additional resources about key features in this release. Join the eCOA community to stay informed.
Help & Support
  • See Pre-Release FAQ for information about the pre-release program.
  • See Vault POD Details to learn how to find your Vault’s POD location.
  • See the Veeva Trust Site for updates regarding system availability. ePRO Vault availability is reported under ePRO Vault, and MyVeeva availability under MyVeeva (ePRO, eConsent).
If you have additional questions, please submit a ticket to Veeva Product Support.

Resolved

November 20 2024,1:00pm PST

November 20 2024,1:00pm PST

Scheduled Maintenance closed.