Veeva Vault 24R3 Release Notice (Self-Serve Pre-Release) - Downtime Required

Maintenance
November 19 2024,7:00pm PST

Veeva Vault 24R3 Release Notice (Self-Serve Pre-Release) - Downtime Required

Status: closed
Start: November 19 2024,3:00pm PST
End: November 19 2024,7:00pm PST
Duration: 4 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs Vault-AP PODs VV3-3086 VV1-24 VV2-2085 VV1-40 VV1-42 VV2-2130 VV1-1156 VV1-1199
Update

November 19 2024,3:00pm PST

November 19 2024,3:00pm PST

Veeva Vault Release Notification

 
What: Veeva Vault 24R3 Upgrade - Pre-Release PODs
Estimated Duration: 2 to 4 hours
Affected PODs: Pre-Release PODs (APAC/EU/US) VV1-24, VV1-40, VV1-42, VV1-1156, VV1-1199, VV2-2085, VV2-2130, VV3-3086  
 
Target DateTuesday, November 19
Target Time: 3:00 pm PST (Wed. Nov. 20 at 12:00 midnight CET/8:00 am JST) 

Changes to the Target Date or Target Time will be posted on the Veeva Trust Site.  
 
   
The Releases tab on Veeva Connect has additional resources and demos about key features in this release. Join the Communities of interest to you and stay informed when new content is added. Additional information can also be found on the About the 24R3 Release page.
 
The 24R3 Pre-Release Program will conclude on January 13, 2025.  
Click here to learn how to find your Vault's POD location.
  
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have further questions, please submit a ticket with Veeva Product Support.

Resolved

November 19 2024,7:00pm PST

November 19 2024,7:00pm PST

Scheduled Maintenance closed.