Veeva Vault 24R3 Release Notification (VV1-1069, 1144 and Veeva Internal) – Downtime Required
Maintenance
November 22 2024,6:00pm PST
Veeva Vault 24R3 Release Notification (VV1-1069, 1144 and Veeva Internal) – Downtime Required
Status: closed
Start:
November 22 2024,2:00pm PST
End:
November 22 2024,6:00pm PST
Duration: 4 hours
Affected Components:
Veeva Vault
Vault-US PODs
Vault-EU PODs
VV2-2122
VV1-1054
VV1-1069
VV1-1140
VV1-1144
Update
November 22 2024,2:00pm PST
November 22 2024,2:00pm PST
Veeva Vault Release Notification
What: Veeva Vault 24R3 General Release
When: Friday, November 22 at 2:00 pm PST / 11:00 pm CET
Estimated Duration: 2 to 4 hours
Affected PODs: Early US/EU Sandbox and Internal PODs
EU: VV2-2122
US: VV1-1054, VV1-1069, VV1-1140, VV1-1144
For the 24R3 General Release:
- About the 24R3 Release has the latest Release Impact Assessment and other critical details
- Latest Announcements include feature-specific information by general release
Click here to learn how to find your Vault's POD location.
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have further questions, please submit a ticket with Veeva Product Support.
Resolved
November 22 2024,6:00pm PST
November 22 2024,6:00pm PST
Scheduled Maintenance closed.
© 2024 Veeva Trust Site