Veeva CRM Maintenance Release - Europe Region

Maintenance
July 18 2024,4:00pm PDT

Veeva CRM Maintenance Release - Europe Region

Status: closed
Start: July 18 2024,2:00pm PDT
End: July 18 2024,4:00pm PDT
Duration: 2 hours
Affected Components:
Veeva CRM Veeva MultiChannel & Integrations MC-01 MC-20 ENGAGE-01 CRM-20
Update

July 18 2024,2:00pm PDT

July 18 2024,2:00pm PDT

Veeva CRM Sandbox and Production orgs will be upgraded to the 241.3.300 release for Online, iOS, and Windows platforms. Systems are generally available during this time.

View Patch Notes

Resolved

July 18 2024,4:00pm PDT

July 18 2024,4:00pm PDT

Scheduled Maintenance closed.